039日記

プリンとともに

【Python】特定バージョンのPython用のpipをインストール

システムに複数のバージョンのpythonが存在している場合、各バージョンのpipをaptでインストールすることができなかったので、対処法を記載しておきます。

例えば、デフォルトでpython3.6が入っていて、python3.7用のpipをインストールしたい場合は以下のコマンドで可能です。

$ python3.7 -m pip install pip

pipのバージョンを指定したい場合は以下のようにします。

$ pip3.7 install sample